HY-Plugins – HY-Slicer 1.3.1 (VST, VST3, AU) [WIN.OSX x86 x64]

By | April 7, 2019

 

Year / Release Date : 03.2019
Version : 1.3.1
Developer : HY-Plugins
Developer site : hy-plugins
Format : VST, VST3, AU
Digit capacity : 32bit, 64bit
Tabletka : present
System requirements : Windows 7 or higher (32/64 bit) OSX 10.9 or higher (32/64 bit).

Description : Virtual Slicer + Step Sequencer + Effect Chain.

 











Leave a Reply

Your email address will not be published. Required fields are marked *

Comment moderation is enabled. Your comment may take some time to appear.